0 votes
by (120 points)
So, my current problems are in Twine 2.3.2. I've been working in Twine for a while and have around 6 stories in my twine application. I have upgraded Twine a couple of times. One story started to malfunction when I attempted to rename it. It would not rename. Then I tried to duplicate it and that went well, but when I tried to delete the old one it would not delete. I still could not rename the new story. Long story short, I now have 3 iterations of this story and have been working in the newest one only. In it, when I added a new passage, it would not immediately appear. I had to close out Twine and reopen for the new passage to appear. It's been working a while like that. Now, I did more writing in the story and I archive every time. When I closed out Twine and reopened it, my updates disappeared. Just now, I imported from file that story from the archive and it replaced all 3 versions of the story with the latest version of the story with my latest updates. It's absolutely crazy.

Got any ideas?

1 Answer

0 votes
by (44.7k points)

Well, first, if you don't already have an archive, make one.  You might also want to publish your files to HTML as well, just to be sure you have copies of everything.

Then, after closing Twine, go to your "C:\Users\(your username)\Documents\Twine" directory and rename the "Stories" folder to something else.  Now re-open Twine and hopefully it should show no stories.  Then import the archive and see if everything looks correct.

The Twine 2.3.x branch had a major change to the underlying engine (it was switched from Node to Electron), so it's still a bit buggy.  Any errors, especially ones you can reproduce, should be added to the Twine issues list (assuming it's not there already).  If, after following the above steps, you still have a problem, you might want to ZIP the archive your made earlier and attach it to the issue, assuming you don't mind other people looking at it.  That way they might be able to see what went wrong with Twine.

In the meanwhile, you might want to use a separate install of Twine v2.2.1, which is currently a bit more stable.  At least until the bugs are worked out.

Hope that helps!  :-)

by (120 points)
Thanks. Yes, your advice is greatly appreciated. I did what you said and renamed the stories folder. When I tried to upload from file, from previous archives, I only found one story, the one I was working on. So it's still buggy. I think I will go back to v2.2.1 for now and wait for the next update.