0 votes
by (170 points)

I am using SugarCube 2.21.0 in Twine 2.

I have noticed that there are extra <br> tags being added into the top of every paragraph that I am creating. Is there any way of making this NOT happen?



1 Answer

+1 vote
by (68.6k points)
edited by

If you're writing your paragraphs naturally, then simply don't add extra line breaks between/around them.  Line breaks are converted to <br> elements, thus extra line breaks generate extra breaks in the output.

If you're wrapping your paragraphs in HTML <p> tags, then either don't do that or use one of the line break control features: line continuations, the <<nobr>> macro, the nobr special tag, or the Config.passages.nobr setting.